• Для скачивания ресурсов Форума пользователь должен написать не менее 5 полезных сообщений и получить 5 симпатий.
    Если Вы не хотите выполнять условия, Вы должны купить переход в группу "Работяга" или любое наше дополнение и сможете скачивать ресурсы, перевод происходит по email, который указывается при оплате.

Решаем ошибку Error: Protected multilib versions

baltun

Смотрящий
Администратор
Сообщения
4.587
Реакции
1.688
Баллы
1.783
Лучшие ответы
2
Решаем ошибку Error: Protected multilib versions при установки компонентов это может проявляться так :

Код:
# yum update -y
Loaded plugins: product-id, rhnplugin, subscription-manager
...
Error: Protected multilib versions: libgcc-4.4.7-4.el6.i686 != libgcc-4.4.7-3.el6.x86_64
Error: Protected multilib versions: glibc-2.12-1.132.el6.i686 != glibc-2.12-1.107.el6_4.5.x86_64
Error: Protected multilib versions: nss-softokn-freebl-3.14.3-9.el6.i686 != nss-softokn-freebl-3.14.3-3.el6_4.x86_64
Для ее решения переходим к файлу /etc/yum.conf и добавляем в него следующую строку:
Код:
protected_multilib=0
У меня это выглядело так:
Код:
[main]
cachedir=/var/cache/yum/$basearch/$releasever
keepcache=0
debuglevel=2
logfile=/var/log/yum.log
exactarch=1
obsoletes=1
gpgcheck=1
plugins=1
protected_multilib = 0
installonly_limit=2
И далее делаем обновление, после обновления желательно файл вернуть в исходное состояние, которое было до добавления строки.
 
Верх Низ